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Introduction
Sizer is a program designed to meet a specific limitation of many existing Windows 
applications. Specifically, Sizer can be used to record the desired window size and location 
for a particular application. This is desirable for those applications that do not record the 
window location and size themselves.

The general procedure is outlined in the Summary, but, in short, Sizer maintains a list of 
recognized applications. If you change the file properties for these applications (i.e., include 
a reference to Sizer), the predetermined screen coordinates maintained by Sizer will be 
used.

Sizer works in both Standard and 386 Enhanced modes. When Sizer is used to start up 
another application, Sizer does not stay resident in memory. It is transparent. It simply loads
the application, sets the window's dimensions, and then exits, allowing you to continue with 
the application, without concern to Sizer's operation. Sizer is compatible with both 
Windows 3.0 and Windows 3.1.

If you have praise, problems, comments, or criticisms, please feel free to contact me. While I
make no guarantees to the effectiveness of this program, I find it quite useful and hope that 
you do too.

Disclaimer: This program is copyright 1992 by Robert M. Ryan. It may be reproduced and 
shared without restriction except that it may not be licensed, nor sold for profit as a software
product. Sizer is a "FreeWare" program (meaning there is no fee for use or copying of the 
program for personal use) and is furnished without warranty of any kind.

Rob Ryan
internet: Robert_Ryan@brown.edu or st802200@brownvm.brown.edu
bitnet: st802200@brownvm
compuserve: 70324,227 (try the other accounts first: I rarely use this one)



Screen Layout
The Sizer screen is comprised of several data entry fields. The most important field in the 
Window is the Command Line field. This is the key field, upon which all of the other fields are
indexed. When the Command Line field is empty, you are not allowed to fill in any of the 
other fields. The Command Line field must be filled first. By selecting different values for the 
Command Line field, you will control which record in the Sizer database will be editted.

The Window Name field is what Sizer uses to determine which window should have it's 
coordinates adjusted. Note that this should match the title of the application window that 
will be resized. While this was manditory on previous releases of Sizer, it is now optional 
except for those programs included in load= line of your WIN.INI file (or in Windows 3.1's 
StartUp Group). Sizer will resize the Window of the specified name, but if no match is found, 
it will resize the current window.

As will be discussed below, the Pick command is useful in filling in the Window Name field 
without needing to manually type in the window title yourself. You can just select, or pick, an
existing Window (assuming that you have started the application in question), and Sizer can
fill in all of the fields based upon the window selected.

There are also four numbers which can be stored, the X and Y coordinates of the upper left 
hand corner of the window and the width and height of the window. By using the check 
boxes to the left of the number fields, you can specify which of these four numbers Sizer 
should use. Thus, for some programs, you may wish to use all four numbers while others, for
example, you may only care about where the Window is placed (leaving it to the application 
to determine the appropriate size).

Finally, in addition to the numeric location and dimensions of the window, you can control 
whether the window should be minimized or maximized. A window that is neither minimized 
nor maximized is "restored".



Syntax
To use Sizer, install it in your Windows directory and add an icon in the Program Manager for
it.

Sizer can be run of one of two modes. If you run "SIZER.EXE", you will get the dialog box in 
which you can specify the various screen dimensions for various applications. If you run 
"SIZER.EXE PROG.EXE", Sizer will run PROG.EXE, using any screen dimensions that have 
been defined for the program by Sizer earlier. See Summary for information on how to 
define these screen dimensions.



Minimize:

A window is minimized when it is as small as possible. This is also called iconic. In most 
cases, a minimized application appears as an icon at the bottom of the screen. It should be 
noted that a minimized application is still in memory, taking up both RAM and CPU time. It is 
just taking up less space on the screen. These minimized applications should not be 
confused with icons in the Program Manager.



Maximize:

A window is maximized when it is as large as possible. This is sometimes called zoomed. In 
most cases, a maximized application takes up the entire screen.



Association:

An association is a linking of files of a particular extension, e.g., .INI, with a particular 
program, e.g., NOTEPAD.EXE. Thus, if you ever double click on a file with an association, it will
run the associated program.



Command Line:

Within Sizer, the term Command Line will be used to refer the the filename (or filespec) of 
the application being used. For example, the Command Line for the PaintBrush program is 
PBRUSH.EXE, or, alternatively, C:\WINDOWS\PBRUSH.EXE. The Command Line may also, for 
certain programs, include optional parameters (often of the form "/x" or "-x" where "x" is any
letter of the alphabet). For the purposes of Sizer, you may ignore these optional parameters
when adding the Command Line text to the Sizer window.



Window Name:

The term Window Name refers to the caption of a window (i.e., the text in the title bar).



File Menu
The file menu provides the basic storage/manipulation of the data on the Sizer screen. 
Commands available from the File Menu include:

New: Enter a new, blank record.
Save: Save current record.
Delete: Delect current record.
Pick: Pick window to pull dimensions from.
Exit: Exit from Sizer.



Help Menu
The Help Menu is fairly self-explanatory. Commands available from the Help Menu include:

Help: This help system.
About: Tell me about the program (version, author, etc.).



The Help Command
The Help command doesn't really need any description. You are using it now.



The About Command
The About command tells you what version of the program you are using. It also says when 
the program was released, and who the author is.



The New Command
The New command, on the File menu, clears the record and allows you to specify a new 
Command Line field. The same result can be yielded by manually erasing the contents of the
Command Line field. See The Screen for more information on the fields of the screen.



The Save Command
The Save command, on the File menu, as its name suggests, saves the contents of the 
current Sizer record to disk. In fact, the changes are written to the WIN.INI file in the 
[Sizer] section. 

NB: If a record has been modified and any attempt to change the Command Line field is 
made, Sizer will warn you that changes must be saved or they will be lost. Selecting "Yes", 
to this query is identical to selecting the Save command from the File menu.



The Delete Command
The Delete command on the File menu is also largely self-explanatory. By selecting Delete,
not only will the record be removed from the screen, but also from the WIN.INI file.



The Pick Command
The Pick Window may, initially, be a little confusing. Once you have specified the 
command line of the application, you need to specify the title of the application's window 
and the screen dimensions to use for that Window. To save you the effort of typing these in 
manually, the Pick Window command has been included under the File menu.

By selecting Pick Window, the mouse becomes a cross-hair and can be used to select a 
window on the screen. As you move this cross-hair cursor (mouse pointer) across the 
different applications, Sizer will fill in the name and dimensions of the window that the 
mouse is over. To accept the specified text and coordinates, click on the left mouse button, 
and the settings will be used and the mouse resumes it's normal function.



The Exit Command
The Exit command, as its name suggests, can be used to exit Sizer.



Summary
The use of this program can be divided into several steps:

1. Determine Program Name: You must first identify the application that you wish to use
Sizer with and get the filename for it. If there is already an icon for this application, 
look at the File Properties (under the Program Manager's File menu) and see what 
is specified under the "command line".

2. Adding Program to Sizer Table: Having determined which program you are going to 
use, you must the create an entry in Sizer for this application. In short, take the 
filename identified in step 1 and fill the Command Line field with this text.

3. Specifying Parameters to Include in Table: Once you have specified the filename, you 
need to specify the other parameters (window dimensions, etc.). The easiest way to 
do this is with the Pick command.

4. Changing Program Parameters to Include Sizer: Once the data in step 3 has been 
saved, you need to modify the File Properties to reflect that you are using Sizer. 
This consists of merely inserting "SIZER.EXE" at the begining of the command line.



Determine Program Name
You must first identify the application that you wish to use Sizer with and get the filename 
for it. 

To do this, you should:

1. Determine which application to use. A suitable application is one that doesn't record 
where its main window is located from one invocation to the next. Also, a suitable 
application would be one that you wish would to have maximized everytime you start
it.

2. Select the icon for this application. So, while in the Program Manager, click once on 
the icon so that name of the icon is highlighted.

3. Select File Properties from the Program Manager's File menu. This will bring up a 
dialog box with two parameters, Description and Command Line. Make a note of the 
Command Line field, for you must insert this in the Command Line field of the Sizer 
program. If you are familiar with the keyboard shortcuts for copy and paste, you can 
highlight the text of the command line and copy it to the clipboard by pressing Ctrl-
Insert. See Adding Program to Sizer Table for more information about what to do with 
this command line text..



Adding Program to Sizer Table
Having determined which program you are going to use, you must the create an entry in 
Sizer for this application. To do this, you should:

1. Start the Sizer program.

2. Take the command line that you identified in Determine Program Name and fill the 
Command Line field with that text, If you used Ctrl-Insert to copy the text to the 
clipboard, you may now use Shift-Insert to paste it in to Sizer. You may omit any 
optional parameters used by the Program Manager.

3. Once that you have filled in the Command Line field, the rest of the window should no
longer be grayed. You may now fill in the rest of the data. See Specifying Parameters 
to Include in Table.



Specifying Parameters to Include in Table
Once you have specified the filename, you need to specify the other parameters (the 
window dimensions, etc.).

1. Specify the Window Name field. This is optional and is the caption text that appears 
at the top of the application's window. Sizer needs this because it sends the sizing 
commands to a Window of this name. If the name is mistyped or is missing, Sizer will
send the sizing commands to the current window. Note that this field is required when
specifying a record for a program that will be started automatically when you start 
Windows.

2. If the program in question is to be included on the load= line of your WIN.INI file, or 
if it is to be placed in Windows 3.1's StartUp group, check the box labeled "Load 
Application on Startup". Otherwise, leave this unchecked. See Using Sizer on StartUp 
for more information.

3. Specify the window dimensions. There are 4 numbers that can be specified: the X and
Y coordinates of the upper left hand corner and the Width and Height of the window. 
Note that if you want Sizer to use these, you must check the Save Origin and Save 
Size buttons as appropriate. Thus, for example, if you don't care about the size, but 
only where Sizer puts the window, check the Save Origin box and fill in the X and Y 
coordinates, but do not check the Save Size box. See The Pick Command for an easier
way to enter the screen coordinates.

4. Select Save from the File menu.



Modify Program Manager Command Line to Include Sizer
Once the Sizer data has been specified for the application (see Specifying Parameters to 
Include in Table), you must modify the Program Manager File Properties to reflect that you 
are using Sizer. To do this, you should:

1. Select the icon for the application. So, while in the Program Manager, click once on 
the icon so that name of the icon is highlighted.

2. Select File Properties from the Program Manager's File menu. This will bring up a 
dialog box with two parameters, Description and Command Line. Insert "SIZER.EXE" 
at the begining of the Command Line field. So, for example, if the command line was 
"PBRUSH.EXE", change it to "SIZER.EXE PBRUSH.EXE".

3. Click on OK to save changes.

4. The icon for the original program will now be incorrect (it will be the Sizer icon). To fix
this, select File Properties from the Program Manager's File menu and click on the 
Icon button. At this new dialog box, specify the filename of the application (i.e. the 
original contents of the Command Line field).

5. Click on OK. to save the icon changes.

6. Click on OK to save all changes.

You may change the sizer settings at any time by running Sizer (by itself) and modify the 
screen dimensions as you wish.



Using Sizer on StartUp
In Windows, you can specify what programs are to be loaded into memory when you start 
Windows. In Windows 3.0, this is done by specifying the load= line of your WIN.INI file. In 
Windows 3.1, this is done by placing items in a special group called "StartUp". Any programs
loaded in this way will automatically be loaded into memory and will be made iconic. But 
how do you use this facility with Sizer? What if you want to control the size of these 
windows when you activate the program in question? Sizer allows you to do this as follows:

1. Create a Sizer entry for the program in question. See Adding Program to Sizer Table 
for more information. Make sure that you check the box "Load Application on 
Startup". Also make sure that you supply the Window Name (generally it is optional, 
but not for startup programs).

2. For Windows 3.0: Insert "sizer.exe" in the load= line of your WIN.INI file. Do not put
the specific name of the program(s) that Sizer will load in the WIN.INI file. Sizer will 
load them for you. See your Windows manual or the text file WININI.TXT for 
information on the load= line of your WIN.INI file.

For Windows 3.1: Using the Program Manager, put a copy of Sizer in the StartUp 
group. This is done by opening the StartUp group, and selecting "New" from the "File"
menu. Just specify the Sizer program and make sure that you check the box, "Run 
Minimized".

Sizer will, the next time you start Windows, load all of the programs for which you checked 
the "Load Application on Startup" box in their respective Sizer entries. Note that Sizer will 
automatically minimize the program for you, but the window's size and location will be 
appropriately set for when the window in question is restored (i.e., made active).

Incidentally, including Sizer in the load= line tells it to load other applications which have 
the "Load Application on Startup" box checked. If, for some reason, you want to have Sizer, 
itself, loaded as an icon on startup, you must create a Sizer record for itself and check the 
"Load Application on Startup" box. Only if you do that can you start Sizer as an minimized 
program on startup.



Defining Associations in File Manager
In many cases, you may wish to use sizer for a program for which you have associations in 
File Manager defined. For example, most systems have all files ending in .INI associated 
with NotePad. This means that if, while in File Manager, if you double click on a file ending 
in .INI, that the system will fire up NotePad so that you can see the contents of the file.

So, what do you do if you want all files of a particular extension to run a program with a 
specified screen size?

1. Well, you first define a Sizer entry for the program in question. For example, if you 
want all files ending in .INI associated with NotePad, define a Sizer entry for 
NOTEPAD.EXE. See Adding Program to Sizer Table for more information.

2. You then, while in File Manager, define the association to include the Sizer program 
name. For example, if all    .INI files are associated with NotePad, then change the 
association from "NOTEPAD.EXE" to "SIZER.EXE NOTEPAD.EXE". 


